Open OnDemand Beginner Question

#1

I am working in connecting OOD to an Open HPC cluster. I have looked at both your 1.4 and 1.5 VMware versions of OOD. I noticed that when I use a desktop to browse to the 1.4 version I get a nice default Open OnDemand website, however when I do the same for VMware 1.5 I just get a default Apache page.

I also have compiled OOD 1.5 based on the manual directions and installed it as a KVM VM machine setup on the cluster from a VNFS file off the head node. When I browse to that OOD I also only get the default Apache website.

The question is how do I move 1.5 to at least the default OOD web page presentation for a browser?

Thanks
Dom

#2

I also have compiled OOD 1.5 based on the manual directions

Does this mean that you didn’t use the rpm?

When I browse to that OOD I also only get the default Apache website.

When you see only the “default Apache” website, what is the URL in the browser?

When you access OnDemand when Apache is properly configured, a request to the base URL / will redirect you to /pun/sys/dashboard and then the Per User NGINX starts as the authenticated user and serves the dashboard:

On the OnDemand node, please verify the right Apache is running:

$ ps faux | grep httpd
efranz    26053  0.0  0.0 103316   828 pts/0    S+   20:02   0:00                          \_ grep httpd
root      17526  0.0  0.1 346636 17332 ?        Ss   Feb05   1:10 /opt/rh/httpd24/root/usr/sbin/httpd
apache    96913  0.0  0.1 374524 18284 ?        S    03:27   0:03  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache    96914  0.0  0.0 361952 12900 ?        S    03:27   0:03  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache    96915  0.0  0.0 361792 12492 ?        S    03:27   0:03  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache    96916  0.0  0.0 361856 12896 ?        S    03:27   0:03  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache    96917  0.0  0.0 362068 12764 ?        S    03:27   0:03  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache    96918  0.0  0.1 374848 18524 ?        S    03:27   0:03  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache    96919  0.0  0.0 361852 12532 ?        S    03:27   0:03  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache    96920  0.0  0.0 361864 12760 ?        S    03:27   0:03  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache     2809  0.0  0.0 361888 12436 ?        S    15:07   0:00  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache     2810  0.0  0.0 361920 12564 ?        S    15:07   0:00  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache     2811  0.0  0.0 361888 12432 ?        S    15:07   0:00  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache     2821  0.0  0.0 361888 12644 ?        S    15:07   0:01  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache     2822  0.0  0.0 361860 12496 ?        S    15:07   0:00  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache     2823  0.0  0.0 361720 12448 ?        S    15:07   0:00  \_ /opt/rh/httpd24/root/usr/sbin/httpd
apache     2824  0.0  0.0 361920 12532 ?        S    15:07   0:00  \_ /opt/rh/httpd24/root/usr/sbin/httpd

Verify /opt/rh/httpd24/root/etc/httpd/conf.d/ood-portal.conf exists and contains the correct virtual hosts. You should have something like:

<VirtualHost *:80>
  RewriteEngine On
  RewriteRule ^(.*) https://ondemand.osc.edu:443$1 [R=301,NE,L]
</VirtualHost>

<VirtualHost *:443>
  ServerName ondemand.osc.edu

  # many directives here, then...

  # Redirect root URI to specified URI
  #
  #     https://ondemand.osc.edu:443/
  #     #=> https://ondemand.osc.edu:443/pun/sys/dashboard
  #
  RedirectMatch ^/$ "/pun/sys/dashboard"

Based on your feedback I’ll be able to provide you more guidance.

#3

I did use the rpm. To build the VNFS image that Open HPC can use to PXE boot nodes including the OOD node it does need to use rpms to build the image that gets
distributed to the nodes. I probably confused the issue when I used the word compiled, sorry about that. Note, both the OOD node that got PXE booted from the Open HPC cluster head node and the version 1.5 VMware version which I downloaded from
https://yum.osc.edu/ondemand/images/ and installed in KVM show the default Apache home page and not the OnDemand home page image shown below in the email. One interesting thing is the 1.4 VMware image I had
tested earlier in KVM did show the OnDemand home page image shown below. That makes me wonder if something has changed in version 1.5 versus 1.4?

Here is what I see when I browse to the OOD server.

This is what is running.

I have attached my ood-portal.conf file for you to take a look at.

Your assistance is very much appreciated.

Thanks

Dominic Daninger |
domd@nor-tech.com

Vice President of Engineering

Direct 952-229-2070 | Cell 612 251 3505 | Fax 952-229-2061

901 E Cliff Rd, Burnsville, Minn. 55337

Nor-tech Logo-1.JPG

(Attachment ood-portal.conf is missing)

#4

Note: This was solved in direct communication outside of Discourse and we are documenting for others benefit.

Problem: Disable Apache Test Page

Solution:
Check if /opt/rh/httpd24/root/etc/httpd/conf.d contains welcome.conf. If so, delete or move welcome.conf and restart the httpd24-httpd service. You may also need to clear broswer history.

Other Useful Debugging Tips:

  1. Run ps faux | grep httpd to verify the right Apache is running. (i.e. /opt/rh/httpd24/root/usr/sbin/httpd)
  2. Verify /opt/rh/httpd24/root/etc/httpd/conf.d/ood-portal.conf exsits and contains the correct virtual hosts
  3. If you’re going to https:// but your ood-portal.conf is set to listen to port 80 which is http:// not https://. You’ll need to generate ood-portal.conf that supports SSL or navigate to http://. We recommend using SSL so it’s best to update your ood-portal.conf to support SSL. (Link to documentation about adding SSL)
#5

Great idea.

Thanks

Dominic Daninger | domd@nor-tech.com

Vice President of Engineering

Direct 952-229-2070 | Cell 612
251 3505 | Fax 952-229-2061

Burnsville, Minn.

People Friendly Technology with a Global Reach