OnDemand Install on CentOS7


#1

Trying to install lastest OnDemand 1.4 on CentOS 7 virtual server. Following the install instructions and stuck on the “Yum install ondemand”. Getting the following:
–> Finished Dependency Resolution
Error: Package: passenger-5.3.7-1.el6.x86_64 (ondemand-web)
Requires: libpcre.so.0()(64bit)
Error: Package: 100:nginx-1.14.0-1.p5.3.7.el6.x86_64 (ondemand-web)
Requires: perl(:MODULE_COMPAT_5.10.1)
Error: Package: passenger-5.3.7-1.el6.x86_64 (ondemand-web)
Requires: ruby(abi) = 1.8
Error: Package: passenger-5.3.7-1.el6.x86_64 (ondemand-web)
Requires: libruby.so.1.8()(64bit)
Error: Package: 100:nginx-1.14.0-1.p5.3.7.el6.x86_64 (ondemand-web)
Requires: libpcre.so.0()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I have installed the missing dependencies but still getting the same error:
yum install pcre.x86_64
yum install ruby-libs.x86_64

Any advice on what I’m missing?


#2

Just to give you a heads up we saw your post and will respond as soon as we have ideas on how to fix your problem. We might be delayed till Monday or Tuesday next week though.


#3

Thank you. Not sure if you made a change already. But I started again with a fresh VM install and was able to successfully install OnDemand. Could be I missed a step on the first try. Moving on to the next section on the install document.


#4

It looks like you installed the CentOS 6 ondemand release RPM and not the CentOS 7 one. Notice how the RPMs getting installed have “el6” in the name, should be “el7”.

Try this:

yum remove ondemand-release-web
yum install https://yum.osc.edu/ondemand/1.4/ondemand-release-web-1.4-1.el7.noarch.rpm


#5

I think I know what I did first time around that failed the install. Under “1. Enable the EPEL and Software Collections repositories:” I only ran the “CentOS 6/7: sudo yum install epel-release centos-release-scl” and skipped the RHEL7 section to install “sudo yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm”. Since I’m installing on CentOS I didn’t think I needed to run something that was tagged only for RHEL 7.
That should probably be changed to “CentOS/RHEL 7” like it is under " 2. Add Open OnDemand’s repository hosted by the Ohio Supercomputer Center:"

I verified this with another fresh install, the install OnDemand fails if you don’t install the RHEL EPEL release.