Internal server error: AuthType openid-connect configured without corresponding module

This is a fresh install of ondemand-selinux (v1.8-1) on cent7.

I’ve configured ondemand based on the ondemand-selinux RPM instructions here: Installation — Open OnDemand 1.8.12 documentation

Everything seems to have gone well except when I try to access the login page, I get a 500 error. The only (relevant?) information I get in the logs at the moment is the following: AH01796: AuthType openid-connect configured without corresponding module. This happens each time I try to access the page and get the 500.

I don’t have openid-connect configured or mentioned however, at least not to my knowledge, anywhere in the config(s).

The only information I have changed in /etc/ood/config/ood_portal.yml is the auth section, which looks like this (and was copied from a prior working instance of Open OnDemand):

servername: ondemand.domain.edu

lua_log_level: ‘debug’

auth:

  • ‘AuthType Basic’
  • ‘AuthBasicProvider ldap’
  • ‘AuthName “Welcome Message.”’
  • ‘AuthLDAPURL “ldapurl”’
  • ‘AuthLDAPBindDN “dnname@domain.local”’
  • ‘AuthLDAPBindPassword supersecretpassword’
  • ‘Require ldap-group CN=sg.Cluster_Users,OU=Security Groups,OU=Research Computing,dc=DOMAIN,DC=local’

I have a feeling I’m missing something quite obvious here but I’m not exactly sure where to look next. Any help is appreciated.

Hi sorry, did you make any progress on this? My guess is there’s some hanging OIDC config somewhere in conf.d/ood_portal.conf. Can you check to see if there’s an unexpected OIDC config in the ood portal.conf file?

Also as an aside - We started shipping ondemand-dex which provides OIDC authentication that can connect to your LDAP so you don’t need to use the basic LDAP config you have there which is not so secure.