Enable InterActive Desktop

Hi Everyone,

Open Ondemand on interactive desktop running It continues to mature well. My file permissions are as follows.

What’s a problem?

root@ondemand bc_desktop]# ll
total 24
-rw-r–r-- 1 root root 2386 Oct 6 18:15 CHANGELOG.md
-rw-r–r-- 1 root root 266 Oct 6 18:15 form.yml
-rw-r–r-- 1 root root 1087 Oct 6 18:15 LICENSE.txt
-rw-r–r-- 1 root root 312 Oct 6 18:15 manifest.yml
-rw-r–r-- 1 root root 2209 Oct 6 18:15 README.md
-rwxr-xr-x 1 root root 35 Oct 6 18:15 submit.yml.erb
drwxr-xr-x 3 root root 64 Oct 19 14:36 template
[root@ondemand bc_desktop]# pwd
/var/www/ood/apps/sys/bc_desktop
[root@ondemand bc_desktop]# cd template/
[root@ondemand template]# ll
total 8
-rwxrwxrwx 1 root root 100 Oct 6 18:15 before.sh.erb
drwxrwxrwx 2 root root 66 Oct 19 14:36 desktops
-rwxrwxrwx 1 root root 525 Oct 25 13:28 script.sh.erb
[root@ondemand template]#

AND …

[root@ondemand bc_desktop]# ls
hpc.yml hpc.yml.bck submit
[root@ondemand bc_desktop]# cat hpc.yml

/etc/ood/config/apps/bc_desktop/oakley.yml


title: “Oakley Desktop”
cluster: “hpc”
attributes:
desktop: “xfce”
batch_connect:
template: “vnc”
nvpasswd: “vnc.passwd”
websockify_cmd: “/usr/bin/websockify”
[root@ondemand bc_desktop]#

[root@ondemand submit]# cat my_submit.yml.erb

/etc/ood/config/apps/bc_desktop/submit/my_submit.yml.erb


batch_connect:
template: “vnc”
script:
job_environment:
SBATCH_EXPORT: “ALL”
native:
- “-N”
- “<%= bc_num_slots.blank? ? 1 : bc_num_slots.to_i %>”
[root@ondemand submit]#

[root@ondemand submit]# cd /home/xfce/ondemand/data/sys/dashboard/batch_connect/sys/bc_desktop/hpc/output/e93d86ab-a941-439e-8a4d-92c7434a5c48/
[root@ondemand e93d86ab-a941-439e-8a4d-92c7434a5c48]# cat output.log
Setting VNC password…
Starting VNC server…

Desktop ‘TurboVNC: xdmod.eduline.local:1 (xfce)’ started on display xdmod.eduline.local:1

Log file is vnc.log
Successfully started VNC server on xdmod.eduline.local:5901…
Script starting…
Starting websocket server…
/var/spool/slurm/d/job00137/slurm_script: line 179: /home/xfce/ondemand/data/sys/dashboard/batch_connect/sys/bc_desktop/hpc/output/e93d86ab-a941-439e-8a4d-92c7434a5c48/script.sh: Permission denied
WebSocket server settings:

  • Listen on :7214
  • No SSL/TLS support (no cert file)
  • Backgrounding (daemon)
    Scanning VNC log file for user authentications…
    Generating connection YAML file…
    Cleaning up…
    Killing Xvnc process ID 21538
    [root@ondemand e93d86ab-a941-439e-8a4d-92c7434a5c48]#

Hi and welcome!

Can you check what line 179 is? I’m not entirely sure if it’ be the same line on our systems.

Hi jeff,

[root@ondemand e93d86ab-a941-439e-8a4d-92c7434a5c48]# cat /home/xfce/ondemand/data/sys/dashboard/batch_connect/sys/bc_desktop/hpc/output/e93d86ab-a941-439e-8a4d-92c7434a5c48/script.sh
#!/usr/bin/env bash

Change working directory to user’s home directory

cd “${HOME}”

Reset module environment (may require login shell for some HPC clusters)

module purge && module restore

Ensure that the user’s configured login shell is used

export SHELL="$(getent passwd $USER | cut -d: -f7)"

Start up desktop

echo “Launching desktop ‘xfce’…”
echo “hadi baslayalim”
source “/home/xfce/ondemand/data/sys/dashboard/batch_connect/sys/bc_desktop/hpc/output/e93d86ab-a941-439e-8a4d-92c7434a5c48/desktops/xfce.sh”
echo “Desktop ‘xfce’ ended…”
[root@ondemand e93d86ab-a941-439e-8a4d-92c7434a5c48]#

this file there isn’t a line :179 :slight_smile:

Hi everyone,

This problem is solutions: NFS share /home on machine is selinux disabled check :wink: