Dashboard Page Load Performance Troubleshooting

Hi All I’m looking to find out what I should expect the page load times to be for moving around the different webpage’s in Open OnDemand (OOD). For example going from the dashboard to files or files back to dashboard and so on.

After moving to OOD 2.0 it can take anywhere between 5-10 seconds to load OOD webpage’s. During this delay either the previous page is still showing or the screen is completely white. Once the new page appears it finishes loading almost instantly. Is this normal? I did notice some unresponsiveness in 1.8 but not to this extent.

Dashboard Landing Page → Files App (9 seconds):

Files → Dashboard Landing Page (6 seconds):

Info About Environment:

  • OS = CentOS 7.9
  • RAM = 128 GB
  • CPU = 28 cores 56 threads
  • OOD = v2.0.18
  • OS Disk = 1 TB HDD SAS Drive
  • Shared File System = GPFS over HDR 100 InfiniBand
  • Auth = OIDC to Keycloak
  • Following suggestions found in another thread ACLs are not configured in the cluster.yml file.

Any suggestions on how I can configure OOD to be more responsive or what I can do to troubleshoot this problem?

Hi, it looks like you’ve done a pretty good job of troubleshooting. Looking at that it took all 6 seconds to download (and maybe interpret?) the javascript.

You see the actual html was fast. Seems like we should be caching those js files. I’ve opened this ticket for the same. Not sure if there’s anything to do unless you want to hack some apache rule to cache them.