TurboVNC seems to no longer have the -nohttpd option

I recently update my compute nodes with the latest patches and fixes. I believe it updated TurboVNC since interactive desktops would no longer work in OOD. I tracked it down to the “-nohttpd” option that is passed to vncserver when the session starts. It appears that the latest TurboVNC on rhel8(rocky 8) dropped that option. I’m using the official TurboVNC repository from turbovnc.org to install it. It looks like I’m on version 2.2.90-20211222.

I was able to temporarily resolve the issue by removing the “-nohttpd” option from the /opt/ood/ondemand/root/usr/share/gems/2.7/ondemand/2.0.20/gems/ood_core-0.18.1/lib/ood_core/batch_connect/templates/vnc.rb file on the OOD server.

Has anyone else had this issue?

Hi Shawn,
Thank you for sharing this!
In addition, we had to add:

unset DBUS_SESSION_BUS_ADDRESS

near the top of the
/var/www/ood/apps/sys/bc_desktop/template/script.sh.erb file, otherwise
the session died with a dbus error:

" - Error in dbus - GDBus.Error:org.freedesktop.DBus.Error.AccessDenied:
Permission denied"

-Dj

@deej

You should set that unset DBUS_SESSION_BUS_ADDRESS globally instead of modifying that template/script.sh.erb that we distribute. It’ll get updated when you update the RPM.

https://osc.github.io/ood-documentation/latest/reference/files/submit-yml-erb.html#setting-batch-connect-options-globally

You can set the header or script_wrapper for all vnc type jobs.

Nice tip! Thanks Jeff!

-Dj