Support/Advice for Rocky Linux?

Hi All,

I’ve been working with some folks who are trying to build a campus cluster using OpenHPC and OnDemand, but we’ve run into a problem - namely, we’d like to use Rocky Linux as the base OS, but installing OnDemand on top of Rocky failed quickly due to the lack of SCL (or my own understanding of the install process). I think I heard that Rocky support was likely coming, but not sure what the timeline is. We’d be happy to help test if there are in-progress docs.

Has anyone installed Open OnDemand on top of Rocky successfully, or have suggestions? I’m not sure how to proceed on an rpm-based distro lacking the SCL option.
Is just installing from source the way to go instead?

Cheers,
Eric C.

We have support for Centos:8, maybe you need to use major version 8 directly instead of 7. It could work out of the box - but in either case SCL is specific to 7 and if Rocky Linux doesn’t have that repo then it’s likely 8 is the only option.

Though, that’s just an off the cuff response without looking into it in. There may be a way to enable the SCL repo on Rocky 7 but I don’t know this for sure.

I installed OnDemand 2.0.13 in a Rocky 8 test VM without any hoopla, just following the “centos 8 guide” at

https://osc.github.io/ood-documentation/latest/installation/install-software.html

Cheers,

Ric

image001.png

image002.png

Thanks, Jeff and Ric!

We are using Rocky 8.4 alongside OpenHPC (Warewulf); forgot to add details earlier! Part of the issue was actually using yum instead of dnf in our Ansible playbook, but now we’ve hit a snag where scl-utils requires /usr/bin/modulecmd, which isn’t provided by LMod.

I’ve opened an issue with OpenHPC, since I suspect this is out of scope for y’all - I’ll update here with any workarounds we find for the sake of sharing.

Cheers,
Eric C.