Ruby dependency error on upgrade to 1.5


#1

I just tried the upgrade from 1.3 to 1.5 in our test instance and got an error about ruby dependencies. See screenshot.

Any suggestions?

Thanks,
Dori


#2

We’re looking into this.


#3

@dsajdak What does yum repolist have? There should be items like centos-sclo-rh and centos-sclo-sclo in the list. My guess is your missing the SCL repositories. If your on CentOS you need to do yum install centos-release-scl.


#4

We mirror the Centos repos here so those are not listed specifically but when I try to install that it says it’s already installed.

This is probably still something on our end though as others have done the upgrade just fine.


#5

None of those mirrored repos look like the SCL repos necessary to install ondemand. You’ll need to mirror the SCL repos. Below are repo configs from stock centos-release-scl and centos-release-scl-rh packages.

[centos-sclo-sclo]
name=CentOS-7 - SCLo sclo
baseurl=http://mirror.centos.org/centos/7/sclo/$basearch/sclo/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-rh]
name=CentOS-7 - SCLo rh
baseurl=http://mirror.centos.org/centos/7/sclo/$basearch/rh/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

#6

I was just getting back to this so thanks for your timely email. This worked great!