Problem displaying non-ASCII characters in OOD SSH client

Hi All,
I’m having a motd in place that creates tables using the terminaltables python module.
It gets displayed correctly when opening up an ssh session from the MobaXterm SSH client.
image
However, this is not the case for the OOD SSH client.
image

I also noticed that LANG has the value C assigned in OOD, whereas in Moba it contains the value C.UTF-8. Simply running export LANG=C.UTF-8 in ~/.bashrc doesn’t help.
Do you have an idea what is wrong here?
Thanks

You can set LANG in /etc/ood/config/nginx_stage.yml like so. Though in 1.7+ we force it to en_US.UTF-8.

# /etc/ood/config/nginx_stage.yml
pun_custom_env:
  LANG: "en_US.UTF-8"

A couple quick tests show that

  • loading ~/.bashrc is after the MOTD (this is why it ididn’t do anything for you)
  • the ssh session on the remote host seems to inherit LANG from the originating process if it’s not set explicitly (this is why setting LANG on the OOD server side may work).

Unfortunately setting LANG to en_US.UTF-8 didn’t help. I’ve printed LANG inside the motd to make sure it really is set correctly. Perhaps there are some other variables that should be changed?
When connecting from Putty and MobaXTerm the table gets displayed correctly. This is not the case for OOD’s web SSH-client and also for mremote.

This is a problem in terminaltable (see https://github.com/Robpol86/terminaltables/issues/57).
Using DoubleTable works fine - so there is nothing wrong with the encoding of OOD’s SSH web client.
Thanks