PBSPro environment issues with OOD

Hello,

We noticed that when we submit jobs through OODs interactive apps that the environment variables PBS_O_LOGNAME and PBS_O_MAIL are always set to root instead of the correct vaules. We are not sure how to go about changing the environment from where the job is submitted to see if we can fix this is or if this is due to something in OOD.

Thanks,

Matt

Matt,

Are those variables set correctly when you start a job through the Job Composer?

Hi,

I work with Matt. The variables are not set correctly when you start a job through the Job Composer. The variables are set to the same incorrect things through job composer and interactive apps.

I looked up the source code, and we don’t modify that anywhere. All that we’re doing for this functionality is passing in parameters to send (-m b or -m be for example). We’re not specifying who to send by, so the system is just using the default. And by system I mean qsub on the ondemand host. Perhaps there’s a setting missing on that host that’s different from, say a login node where uses submit through ssh?

That said, you can pass environment variables to interactive jobs. This is what that looks like. It’s the job_environment attribute under script.

script:
  job_environment:
     PBS_O_MAIL: "cluster-mailer@cluster.org"
     FOO: "bar"

Hope that helps!

We’ll look into that further. Good to know that it doesn’t get modified. Thanks for the feedback. I’ll let y’all know if I have more questions/feedback.

Folks,

Apologies for not responding with this idea earlier. This question is essentially a duplicate of Question About Passing Environment Variables for PBS Job.

The idea is to write a wrapper for qsub to SSH to a login node and launch from there. To support that sort of workflow many of OnDemand’s adapters including the one for PBSPro support overriding the default scheduler commands (qsub, qstat, …) using the bin_overrides section of the PBSPro cluster config.