Open OnDemand repo is not working


#1

Per this documentation: https://osc.github.io/ood-documentation/master/release-notes/v1.4-release-notes.html

I should be able to download new repo and new packages for version 1.4 from here: https://yum.osc.edu/ondemand/1.4/ondemand-release-web-1.4-1.el7.noarch.rpm

Server blocks requests over HTTPS/HTTP.

Could you fix this, as I am planning to upgrade our OnDemand instance.

Thank you.


#2

My apologies, we are having a system wide downtime today and unfortunately that appears to include yum.osc.edu.


#3

Seeing same problem here at The University of Arizona; PING repo.hpc.osc.edu (192.148.247.146) succeeds, but connections to either port 80 or 443 time out.

Ric


#4

Sorry to hear that, hope you will resolve the issue soon.
Please drop the line here when the repo will be available.

Thank you.


#5

I opened an issue to track here https://github.com/OSC/ondemand-packaging/issues/41

Also @anton I think we will release 1.5 at the end of next week so you might want to wait till then before upgrading.


#6

Just to be clear, today was our regularly scheduled quarterly maintenance window where we take everything offline for a bit. Obviously we have found a gap in our planning / notification system regarding the repos that we’ll need to address prior to our next quarterly downtime. Systems are starting to come back up and are going through internal testing before we expose them to the outside world. I’d expect everything to be back to normal within about an hour or so.


#7

Alan,

Thank you for the update.

Franz,

Is Slurm 19 going to be supported by version 1.5?

Thanks


#8

We fixed https://github.com/OSC/ood_core/issues/99 which was a work around for the Slurm 18 bug. Assuming there is backwards compatibility between 19 and 18 and no new bugs were introduced it should work with Slurm 19. I’ll add a task to test and verify Slurm 19 this week.


#9

Thank you for the update.


#10

Our systems are back in production and https://yum.osc.edu is available again.