Open in terminal OOD2

In ondemand-2.0.13, the files app “open in terminal” button from my $HOME correctly opens
https://ooddev.hpc.arizona.edu/pun/sys/shell/ssh/default/home/ric
Also in that button is a right arrow and a dropdown listing cluster names found in /etc/ood/clusters.d. Clicking any of the cluster names gives a “page not found”. The generated URL is
https://ooddev.hpc.arizona.edu/pun/sys/dashboard/ssh/shell.hpc.arizona.edu/home/ric
If I replaced /dashboard/ with /shell/ in the address bar, it opens a command line window as expected.
I’ve tried various settings of DEFAULT_SSHHOST in shell/env and “OOD_SSH_HOSTS” in desktop/env to no effect.

FWIW, Cluster->xxx shell access works as expected. Also the configuration I had for this worked in OOD 1.8, where the URL contained /shell/ in all cases.

Any ideas how to make the items pulled from cluster.d produce a valid URL, or simply take them off the “open in terminal” button (since all the cluster share the same submission nodes).

Thanks, @azric this is a bug. It should work as you expect and surprisingly nobody has mentioned this before now leading me to suspect how good of a feature it is.

In any case, it’s just a bug on our side that we’ll have to fix. Thanks for letting us know!