OOD job composer and active jobs failed to work after upgrade


#1

Recently I upgraded OOD from 1.3 to 1.5. Before the upgrade, everything worked fine. After the upgrade, Job Composer and Active Jobs don’t work properly. The Active Jobs app shows something wrong with the control buttons where we could select which jobs and which cluster. The Job Composer app always stays in the status as show in the screen shot.

OOD is installed on a cluster using CentOS 7 and Slurm 17.11. Interactive Apps work fine after the upgrade.

Ping


#2

@pingluo just adding this to explain to others how to fix the problem

We discovered that for Active Jobs and Job Composer under /var/www/ood/apps/sys/myjobs/public/assets and /var/www/ood/apps/sys/activejobs/public/assets there were old .sprockets-manifest- files along with older css and js assets that needed to be deleted.

If you upgrade from 1.0, 1.1, 1.2 to 1.5 you need to ensure these are deleted as the rpm install will not delete these. The right way is to follow the directions for upgrading to 1.3 from 1.2 https://osc.github.io/ood-documentation/master/release-notes/v1.3-release-notes.html, at least steps 1 and steps 2. Then go ahead and follow the directions for adding the appropriate rpm repo for https://osc.github.io/ood-documentation/master/release-notes/v1.5-release-notes.html#upgrading-from-v1-3