OOD and Dask Labextension

I’m trying to use the combination of OOD, jupyterlab, and dask-jobqueue, which I’m sure must be a fairly common scenario here :slight_smile:
It is pretty much working - except for the Dask Labextension. The extension itself works fine; if I start the jupterlab instance manually on the login node (with appropriate ssh port forwards) everything is just dandy.

However, through OOD it doesn’t work.

If I put the following into the Labextension search bar:

https://[OOD-web-server]/node/[nodename]/[port]/proxy/8787/status

then it seems to at least actually find the cluster (all the buttons light up orange instead of grey) but launching any of the tabs from the extension just gives me blank pages.

I notice that in my browser network traffic it is doing some sort of web services request?
wss://[OOD-web-server]/node/[nodename]/[port]/proxy/8787/individual-progress/ws
and getting back a 403 forbidden, which I assume is part of the issue here.

Anybody got this to work?

Cheers

David

Found a little more info - it seems that the request is making it all the way through to the jupyterlab instance, since I’m seeing this in the jupyterlab output:

403 GET /node/rei-n1/4367/proxy/8787/individual-progress/ws (10.0.16.254) 1.72ms referer=None

so I’m not sure if this is an OOD problem or a jupyterlab issue at this point.

I think you’re on the right track, though I don’t know much about this extension.

Here’s an issue from them itself, looks like there’s a setting 'allow_websocket_origin': ['*'] you may need (to set to either * or the ondemand host).

I also found this which may or may not help.

After a couple of days adding random print statements all over jupyter code, I’m fairly sure this is actually a jupyter issue; I think it isn’t checking the allow_websocket_origin setting in the jupyter_server_proxy code, so I’ve raised an issue (I’ve actually raised it against the extension at the moment since I don’t know enough about jupyter to know which level the check should be implemented in).

Thanks for your help!