Not a registered developer

#1

When I try to go to my sandbox development area, I get this error:

You are not a registered developer for this portal. Please contact bridges@psc.edu for more information on how to register.

I enabled OOD_APP_DEVELOPMENT:

[root@vm039 sys]# cat !$
cat /etc/ood/config/apps/dashboard/env
OOD_DASHBOARD_TITLE=“Bridges OnDemand”
OOD_PORTAL=“ondemand”

BOOTSTRAP_NAVBAR_INVERSE_BG=’#496882
BOOTSTRAP_NAVBAR_INVERSE_LINK_COLOR=’#dee6ec
#BOOTSTRAP_NAVBAR_INVERSE_BG=‘rgb(68,68,68)’
#BOOTSTRAP_NAVBAR_INVERSE_LINK_COLOR=‘rgb(255,255,255)’

MOTD_PATH="/etc/motd"

… new users are not allowed to put more than 2 links in a post and these lines were being interpreted as links …

OOD_APP_DEVELOPMENT=1

And added a few names to ood.rb:

[root@vm039 sys]# cat /etc/ood/config/apps/dashboard/initializers/ood.rb
OodFilesApp.candidate_favorite_paths.tap do |paths|

FIXME: would be nice to add a path and a title

add project space directories

paths.concat User.new.groups.map(&:name).map { |g|
Pathname.new("/vault/#{g}/#{User.new.name}")
}

add scratch space directories

paths.concat User.new.groups.map(&:name).map { |g|
Pathname.new("/pylon5/#{g}/#{User.new.name}")
}
end

Configuration.app_development_enabled = %w(
susan jasons nigra gomez welling blood
).include?(OodSupport::User.new.name)

At one point, I added a password for myself as instructed in the docs, but think that wasn’t needed as we use LDAP. Could that be what’s getting in my way?

I didn’t find anything else on this discourse. Thanks for any pointers.

Susan Litzinger
PSC
(installing release 1.5)
412-268-8263

#2

Susan,

Will you format your post to place three backticks around the blocks of code so that it formats well? Some of the comments in the code are being rendered by Discourse as headers.

This might be difficult to parse: https://osc.github.io/ood-documentation/master/app-development/enabling-development-mode.html

Basically

In OnDemand 1.3, the app root for a dev app was set in the PUN config to '~%{owner}/%{portal}/dev/%{name}'

In OnDemand 1.4, the app root for a dev app has been changed to '/var/www/ood/apps/dev/%{owner}/gateway/%{name}'

You can fix it two ways:

  1. Revert to 1.3 style by changing value in /etc/ood/config/nginx_stage.yml
  2. Make the directory and symlinks required for the 1.4 default value for the users you want to enable.
#3

I’m misunderstanding something here. The current nginx_stage.yml in release 1.5 looks like this – and I’m assuming that the lines that are commented out are the default, correct?

#app_root:
#  dev: '~%{owner}/%{portal}/dev/%{name}'
#  usr: '/var/www/ood/apps/usr/%{owner}/gateway/%{name}'
#  sys: '/var/www/ood/apps/sys/%{name}'

So you suggest I change it to 1.3 style, but it looks like it already is 1.3 style, no? I uncommented it, restarted the web server but got the same error so that’s why I’m a little confused.

thanks much - S

#4

I think I’m only at v 1.4:

[root@vm039 sys]# grep VERSION /opt/ood/nginx_stage/lib/nginx_stage/version.rb 
  VERSION = "1.4.5"
#5

Sorry … I’m at ondemand 1.5:

[root@vm039 sys]# rpm -qa | grep ondemand
ondemand-nginx-filesystem-1.14.0-2.p5.3.7.el7.noarch
ondemand-runtime-1.5-5.el7.x86_64
ondemand-release-web-1.5-1.el7.noarch
ondemand-nodejs-1.5-5.el7.x86_64
ondemand-git-1.5-5.el7.x86_64
ondemand-passenger-5.3.7-2.el7.x86_64
ondemand-apache-1.5-5.el7.x86_64
ondemand-ruby-1.5-5.el7.x86_64
ondemand-1.5.5-1.el7.x86_64
ondemand-nginx-1.14.0-2.p5.3.7.el7.x86_64
#6

That is concerning. Is this the file /etc/ood/config/nginx_stage.yml? Is there another app_root anywhere in the yaml file, or is that the only one? So if you have

app_root:
  dev: '~%{owner}/%{portal}/dev/%{name}'
  usr: '/var/www/ood/apps/usr/%{owner}/gateway/%{name}'
  sys: '/var/www/ood/apps/sys/%{name}'

Then if you access it as user1 it should attempt to do mkpath on “~user1/ondemand/dev”. That attempt is failing.

When you say you restarted the web server you did that from the help menu?

Thanks,
Eric

#7

Un-commenting all those lines and making sure they were lines up seems to have fixed the ‘Not a registered developer’ issue. (I thought those were the default values and you only needed to un-comment them if you wanted to change them. Not the case, or so it seems.) And yes, I restarted the web server from the ‘Develop’ menu. Never knew you could do it under the ‘Help’ menu. Thanks Eric!

Now onto getting R Studio up.