Nginx_stage.yml changes not working

Made the following changes in the nginx_state.yml file and it is not appearing on the dashboard…

pun_custom_env:
OOD_DASHBOARD_TITLE: “Texas Tech High Performance Computing Center”
OOD_DASHBOARD_LOGO: “/var/www/ood/public/TTUHPCClogo.png”

It’s yml, so I’d ask if it’s indented right. The example you have isn’t. Also, as a side note, we have ansible automation available to help with simple little things like this.

pun_custom_env:
  OOD_DASHBOARD_TITLE: "Texas Tech High Performance Computing Center"
  OOD_DASHBOARD_LOGO: "var/www/ood/public/TTUHPCClogo.png"

For some reason when I pasted it it did not show the two spaces at the beginning of the 2nd and 3rd lines which is consistent with the other idents? It loses the two spaces when it displays it your view window.

pun_custom_env:
OOD_DASHBOARD_TITLE: “Texas Tech High Performance Computing Center”
OOD_DASHBOARD_LOGO: "/var/www/ood/public/TTUHPCClogo.png

I will take a look at the ansible playbook option.

I see. If the indentations are correct, then you may just need to restart your webserver for it to take affect (you can up at the top right of the dashboard).

It is now working after restarting.I guess from now on I will restart the server whenever a change is made?

For anything in nginx_stage.yml - yes. Somethings are cached, other things are pulled up on every page load, but yea, it doesn’t hurt to restart in your testing something and don’t see it immediately.