Install issues on Centos 6


#1

We are trying to install open ondemand on a Centos 6 system and we are haing all sorts of problems with the scl repositories. We have yum installed the centos-release-scl repositories and have the CentOS-SCLo-scl-rh.repo there, however when we do yum lists on things in this repository we are not finding the versions of some of the dependencies that are required. When we do the yum install it requires git19 rh-ruby22 and some other pieces that are housed in the scl rh repository. Going to the repository on the web we can see the packages, however yum cannot find them. I did a tedious install of git19 by hand and then that requirement was met but do not want to have to git it for each and every piece by hand.

Help


#2

Here is a partial yum list of rh-ruby* since it thinks some of it are links.

Available Packages
rh-ruby23.x86_64 2.2-7.el6 centos-sclo-rh
rh-ruby23-build.x86_64 2.2-7.el6 centos-sclo-rh
rh-ruby23-ruby.x86_64 2.3.6-67.el6 centos-sclo-rh
rh-ruby23-ruby-devel.x86_64 2.3.6-67.el6 centos-sclo-rh
rh-ruby23-ruby-doc.noarch 2.3.6-67.el6 centos-sclo-rh
rh-ruby23-ruby-irb.noarch 2.3.6-67.el6 centos-sclo-rh
rh-ruby23-ruby-libs.x86_64 2.3.6-67.el6 centos-sclo-rh
rh-ruby23-ruby-tcltk.x86_64 2.3.6-67.el6 centos-sclo-rh
rh-ruby23-rubygem-bigdecimal.x86_64 1.2.8-67.el6 centos-sclo-rh
rh-ruby23-rubygem-bundler.noarch 1.10.6-4.el6 centos-sclo-rh
rh-ruby23-rubygem-bundler-doc.noarch 1.10.6-4.el6 centos-sclo-rh
rh-ruby23-rubygem-did_you_mean.x86_64 1.0.0-67.el6 centos-sclo-rh
rh-ruby23-rubygem-io-console.x86_64 0.4.5-67.el6 centos-sclo-rh
rh-ruby23-rubygem-json.x86_64 1.8.3.1-67.el6 centos-sclo-rh
rh-ruby23-rubygem-minitest.noarch 5.8.5-67.el6 centos-sclo-rh
rh-ruby23-rubygem-net-telnet.x86_64 0.1.1-67.el6 centos-sclo-rh
rh-ruby23-rubygem-power_assert.noarch 0.2.6-67.el6 centos-sclo-rh
rh-ruby23-rubygem-psych.x86_64 2.1.0.1-67.el6 centos-sclo-rh
rh-ruby23-rubygem-rake.noarch 10.4.2-67.el6 centos-sclo-rh
rh-ruby23-rubygem-rdoc.noarch 4.2.1-67.el6 centos-sclo-rh
rh-ruby23-rubygem-test-unit.noarch 3.1.5-67.el6 centos-sclo-rh
rh-ruby23-rubygems.noarch 2.5.2.2-67.el6 centos-sclo-rh
rh-ruby23-rubygems-devel.noarch 2.5.2.2-67.el6 centos-sclo-rh
rh-ruby23-runtime.x86_64 2.2-7.el6 centos-sclo-rh
rh-ruby23-scldevel.x86_64 2.2-7.el6 centos-sclo-rh
rh-ruby24.x86_64 2.4-2.el6 centos-sclo-rh
rh-ruby24-build.x86_64 2.4-2.el6 centos-sclo-rh
rh-ruby24-ruby.x86_64 2.4.3-90.el6 centos-sclo-rh
rh-ruby24-ruby-devel.x86_64 2.4.3-90.el6 centos-sclo-rh
rh-ruby24-ruby-doc.noarch 2.4.3-90.el6 centos-sclo-rh
rh-ruby24-ruby-irb.noarch 2.4.3-90.el6 centos-sclo-rh
rh-ruby24-ruby-libs.x86_64 2.4.3-90.el6 centos-sclo-rh
rh-ruby24-rubygem-bigdecimal.x86_64 1.3.0-90.el6 centos-sclo-rh
rh-ruby24-rubygem-bundler.noarch 1.13.7-1.el6 centos-sclo-rh
rh-ruby24-rubygem-bundler-doc.noarch 1.13.7-1.el6 centos-sclo-rh
rh-ruby24-rubygem-did_you_mean.x86_64 1.1.0-90.el6 centos-sclo-rh
rh-ruby24-rubygem-io-console.x86_64 0.4.6-90.el6 centos-sclo-rh
rh-ruby24-rubygem-json.x86_64 2.0.4-90.el6 centos-sclo-rh
rh-ruby24-rubygem-minitest.noarch 5.10.1-90.el6 centos-sclo-rh
rh-ruby24-rubygem-net-telnet.x86_64 0.1.1-90.el6 centos-sclo-rh
rh-ruby24-rubygem-openssl.x86_64 2.0.5-90.el6 centos-sclo-rh
rh-ruby24-rubygem-power_assert.noarch 0.4.1-90.el6 centos-sclo-rh
rh-ruby24-rubygem-psych.x86_64 2.2.2-90.el6 centos-sclo-rh
rh-ruby24-rubygem-rake.noarch 12.0.0-90.el6 centos-sclo-rh
rh-ruby24-rubygem-rdoc.noarch 5.0.0-90.el6 centos-sclo-rh
rh-ruby24-rubygem-test-unit.noarch 3.2.3-90.el6 centos-sclo-rh
rh-ruby24-rubygem-xmlrpc.noarch 0.2.1-90.el6 centos-sclo-rh
rh-ruby24-rubygems.noarch 2.6.14-90.el6 centos-sclo-rh
rh-ruby24-rubygems-devel.noarch 2.6.14-90.el6 centos-sclo-rh
rh-ruby24-runtime.x86_64 2.4-2.el6 centos-sclo-rh
rh-ruby24-scldevel.x86_64


#3

In doing a little more searching on the web, it appears that the ondemand rpm is trying to load deprecated software that is no longer handled in the scl rh repositories?


#4

here is what it is looking for that may be deprecated:

–> Finished Dependency Resolution
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: rh-ruby22-rubygem-bundler
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: rh-ruby22-rubygem-rake
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: nginx16
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: rh-ruby22-rubygems
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: rh-ruby22
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: nodejs010
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: rh-ruby22-rubygems-devel
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: rh-ruby22-ruby-devel
Error: Package: ondemand-1.3.7-2.el6.x86_64 (ondemand-web)
Requires: rh-passenger40


#5

We have run into this when building RPMs for EL6. We are in the process of updating dependencies but until that’s done your going to have to update your SCL repo file to point to archived versions of SCL. Change /etc/yum.repos.d/CentOS-SCLo-scl-rh.repo to have baseurl=http://vault.centos.org/6.8/sclo/x86_64/rh/ for the repo centos-sclo-rh. Once that’s done do “yum clean all” and try and install ondemand again.


#6

Thank you. The install is now working by the looks of it.