Directory Copy and Paste issue with Lustre


#1

Hello,
We are facing an issue with directory copy and paste via File Explorer. It’s working ok with normal NFS share or local folders, but when I copy and paste a folder within Lustre share or from Lustre to other locations. Inside contents are missing.

I have tested from other locations to Lustre share and it worked fine. Any advice would be appreciated.

Thank you


#2

Unfortunately I’m unable to reproduce the issue, but the code that does this is an old version of https://github.com/coderaiser/node-copymitter: https://github.com/coderaiser/node-copymitter/tree/v1.8.10

Up until 1.4 we couldn’t update this dependency. I’m investigating what version we can update to and verify the app is functional as before. If it is I’ll give you a test that you try to see if it fixes the problem.


#3

So you could try this. If using OnDemand 1.4, you can cd /var/www/ood/apps/sys/files/ then edit lib/cloudcmd/package.json and change "copymitter": "1.8.10", to "copymitter": "3.2.3",. Then in the root directory of the app run bin/setup and it will rebuild the app with the updated dependency.

I do not know if this will address the problem you are facing or not though. If it does let me know and I’ll be sure to get this dependency update in the 1.5 release.

One thing I noticed while testing this is that at OSC on our web nodes directories like the project and scratch space ones auto-mount after you first cd to that directory. This means getting a listing of the project and scratch space directories before cd-ing to that directory doesn’t work. I doubt something like that is in play for you here but just thought I’d mention it.


#4

Thanks for taking care of this issue. We are using 1.4 and I ran bin/setup but I got the following error.

[root@ood-dev files]# cat /var/www/ood/apps/sys/files/lib/cloudcmd/package.json | grep copymitter
    "copymitter": "3.2.3",
[root@ood-dev files]# bin/setup
cd /var/www/ood/apps/sys/files

== Building Files App ==

== Installing dependencies ==
rm -rf node_modules
npm install --production --prefix tmp yarn
/usr/share/gems/gems/rake-0.9.6/lib/rake/file_utils.rb:53:in `block in create_shell_runner': Command failed with status (127): [npm install --production --prefix tmp yarn...] (RuntimeError)
	from /usr/share/gems/gems/rake-0.9.6/lib/rake/file_utils.rb:45:in `call'
	from /usr/share/gems/gems/rake-0.9.6/lib/rake/file_utils.rb:45:in `sh'
	from /usr/share/gems/gems/rake-0.9.6/lib/rake/file_utils_ext.rb:40:in `sh'
	from bin/setup:30:in `block in <main>'
	from /usr/share/ruby/fileutils.rb:125:in `chdir'
	from /usr/share/ruby/fileutils.rb:125:in `cd'
	from /usr/share/gems/gems/rake-0.9.6/lib/rake/file_utils_ext.rb:40:in `chdir'
	from bin/setup:10:in `<main>'

#5

Hello efranz,

I was able to download the files from https://github.com/OSC/ood-fileexplorer and ran scl enable rh-git29 rh-ruby24 rh-nodejs6 -- bin/setup and sudo rsync -rlptv --delete . /var/www/ood/apps/sys/files for test.

However, it didn’t resolve the problem.


#6

Hmm. So I’ll investigate setting up another test you can run so maybe we can patch the app with a different copy mechanism to use than the one that is currently being used. I won’t be able to work on this till mid this week but will keep you posted.