Dependency issues when updating to Centos 7.9

I fear this is a dumb question but I’m having issues with running yum updates to update to Centos 7.9. We have ondemand-1.8.19-4.el7.x86_64 installed but when I run yum update I get a bunch of dependency issues:

Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-ruby < 2.0
Removing: ondemand-ruby-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-ruby = 1.8-1.el7
Updated By: ondemand-ruby-2.0-1.el7.x86_64 (ondemand-web)
ondemand-ruby = 2.0-1.el7
Available: ondemand-ruby-1.5-5.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.5-5.el7
Available: ondemand-ruby-1.6-1.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.6-1.el7
Available: ondemand-ruby-1.6-2.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.6-2.el7
Available: ondemand-ruby-1.7-2.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-2.el7
Available: ondemand-ruby-1.7-3.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-3.el7
Available: ondemand-ruby-1.7-4.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-4.el7
Available: ondemand-ruby-1.7-5.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-5.el7
Available: ondemand-ruby-1.7-6.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-6.el7
Available: ondemand-ruby-1.7-7.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-7.el7
Available: ondemand-ruby-1.7-8.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-runtime < 1.9
Removing: ondemand-runtime-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-runtime = 1.8-1.el7
Updated By: ondemand-runtime-2.0-1.el7.x86_64 (ondemand-web)
ondemand-runtime = 2.0-1.el7
Available: ondemand-runtime-1.5-5.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.5-5.el7
Available: ondemand-runtime-1.6-1.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.6-1.el7
Available: ondemand-runtime-1.6-2.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.6-2.el7
Available: ondemand-runtime-1.7-2.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-2.el7
Available: ondemand-runtime-1.7-3.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-3.el7
Available: ondemand-runtime-1.7-4.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-4.el7
Available: ondemand-runtime-1.7-5.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-5.el7
Available: ondemand-runtime-1.7-6.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-6.el7
Available: ondemand-runtime-1.7-7.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-7.el7
Available: ondemand-runtime-1.7-8.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-runtime < 2.0
Removing: ondemand-runtime-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-runtime = 1.8-1.el7
Updated By: ondemand-runtime-2.0-1.el7.x86_64 (ondemand-web)
ondemand-runtime = 2.0-1.el7
Available: ondemand-runtime-1.5-5.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.5-5.el7
Available: ondemand-runtime-1.6-1.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.6-1.el7
Available: ondemand-runtime-1.6-2.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.6-2.el7
Available: ondemand-runtime-1.7-2.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-2.el7
Available: ondemand-runtime-1.7-3.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-3.el7
Available: ondemand-runtime-1.7-4.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-4.el7
Available: ondemand-runtime-1.7-5.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-5.el7
Available: ondemand-runtime-1.7-6.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-6.el7
Available: ondemand-runtime-1.7-7.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-7.el7
Available: ondemand-runtime-1.7-8.el7.x86_64 (ondemand-web)
ondemand-runtime = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-python < 1.9
Removing: ondemand-python-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-python = 1.8-1.el7
Updated By: ondemand-python-2.0-1.el7.x86_64 (ondemand-web)
ondemand-python = 2.0-1.el7
Available: ondemand-python-1.7-2.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-2.el7
Available: ondemand-python-1.7-3.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-3.el7
Available: ondemand-python-1.7-4.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-4.el7
Available: ondemand-python-1.7-5.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-5.el7
Available: ondemand-python-1.7-6.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-6.el7
Available: ondemand-python-1.7-7.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-7.el7
Available: ondemand-python-1.7-8.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-ruby < 1.9
Removing: ondemand-ruby-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-ruby = 1.8-1.el7
Updated By: ondemand-ruby-2.0-1.el7.x86_64 (ondemand-web)
ondemand-ruby = 2.0-1.el7
Available: ondemand-ruby-1.5-5.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.5-5.el7
Available: ondemand-ruby-1.6-1.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.6-1.el7
Available: ondemand-ruby-1.6-2.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.6-2.el7
Available: ondemand-ruby-1.7-2.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-2.el7
Available: ondemand-ruby-1.7-3.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-3.el7
Available: ondemand-ruby-1.7-4.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-4.el7
Available: ondemand-ruby-1.7-5.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-5.el7
Available: ondemand-ruby-1.7-6.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-6.el7
Available: ondemand-ruby-1.7-7.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-7.el7
Available: ondemand-ruby-1.7-8.el7.x86_64 (ondemand-web)
ondemand-ruby = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-python < 2.0
Removing: ondemand-python-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-python = 1.8-1.el7
Updated By: ondemand-python-2.0-1.el7.x86_64 (ondemand-web)
ondemand-python = 2.0-1.el7
Available: ondemand-python-1.7-2.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-2.el7
Available: ondemand-python-1.7-3.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-3.el7
Available: ondemand-python-1.7-4.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-4.el7
Available: ondemand-python-1.7-5.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-5.el7
Available: ondemand-python-1.7-6.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-6.el7
Available: ondemand-python-1.7-7.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-7.el7
Available: ondemand-python-1.7-8.el7.x86_64 (ondemand-web)
ondemand-python = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-apache < 2.0
Removing: ondemand-apache-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-apache = 1.8-1.el7
Updated By: ondemand-apache-2.0-1.el7.x86_64 (ondemand-web)
ondemand-apache = 2.0-1.el7
Available: ondemand-apache-1.5-5.el7.x86_64 (ondemand-web)
ondemand-apache = 1.5-5.el7
Available: ondemand-apache-1.6-1.el7.x86_64 (ondemand-web)
ondemand-apache = 1.6-1.el7
Available: ondemand-apache-1.6-2.el7.x86_64 (ondemand-web)
ondemand-apache = 1.6-2.el7
Available: ondemand-apache-1.7-2.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-2.el7
Available: ondemand-apache-1.7-3.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-3.el7
Available: ondemand-apache-1.7-4.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-4.el7
Available: ondemand-apache-1.7-5.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-5.el7
Available: ondemand-apache-1.7-6.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-6.el7
Available: ondemand-apache-1.7-7.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-7.el7
Available: ondemand-apache-1.7-8.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-nginx = 1.17.3
Removing: ondemand-nginx-1.17.3-7.p6.0.4.el7.x86_64 (@ondemand-web)
ondemand-nginx = 1.17.3-7.p6.0.4.el7
Updated By: ondemand-nginx-1.18.0-1.p6.0.7.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.18.0-1.p6.0.7.el7
Available: ondemand-nginx-1.14.0-1.p5.3.7.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.14.0-1.p5.3.7.el7
Available: ondemand-nginx-1.14.0-2.p5.3.7.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.14.0-2.p5.3.7.el7
Available: ondemand-nginx-1.17.3-2.p6.0.4.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.17.3-2.p6.0.4.el7
Available: ondemand-nginx-1.17.3-3.p6.0.4.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.17.3-3.p6.0.4.el7
Available: ondemand-nginx-1.17.3-4.p6.0.4.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.17.3-4.p6.0.4.el7
Available: ondemand-nginx-1.17.3-5.p6.0.4.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.17.3-5.p6.0.4.el7
Available: ondemand-nginx-1.17.3-6.p6.0.4.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.17.3-6.p6.0.4.el7
Available: ondemand-nginx-1.17.3-8.p6.0.4.el7.x86_64 (ondemand-web)
ondemand-nginx = 1.17.3-8.p6.0.4.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-passenger = 6.0.4
Removing: ondemand-passenger-6.0.4-7.el7.x86_64 (@ondemand-web)
ondemand-passenger = 6.0.4-7.el7
Updated By: ondemand-passenger-6.0.7-1.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.7-1.el7
Available: ondemand-passenger-5.3.7-1.el7.x86_64 (ondemand-web)
ondemand-passenger = 5.3.7-1.el7
Available: ondemand-passenger-5.3.7-2.el7.x86_64 (ondemand-web)
ondemand-passenger = 5.3.7-2.el7
Available: ondemand-passenger-6.0.3-2.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.3-2.el7
Available: ondemand-passenger-6.0.4-1.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.4-1.el7
Available: ondemand-passenger-6.0.4-2.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.4-2.el7
Available: ondemand-passenger-6.0.4-3.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.4-3.el7
Available: ondemand-passenger-6.0.4-4.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.4-4.el7
Available: ondemand-passenger-6.0.4-5.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.4-5.el7
Available: ondemand-passenger-6.0.4-6.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.4-6.el7
Available: ondemand-passenger-6.0.4-8.el7.x86_64 (ondemand-web)
ondemand-passenger = 6.0.4-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-nodejs < 2.0
Removing: ondemand-nodejs-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-nodejs = 1.8-1.el7
Updated By: ondemand-nodejs-2.0-1.el7.x86_64 (ondemand-web)
ondemand-nodejs = 2.0-1.el7
Available: ondemand-nodejs-1.5-5.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.5-5.el7
Available: ondemand-nodejs-1.6-1.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.6-1.el7
Available: ondemand-nodejs-1.6-2.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.6-2.el7
Available: ondemand-nodejs-1.7-2.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-2.el7
Available: ondemand-nodejs-1.7-3.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-3.el7
Available: ondemand-nodejs-1.7-4.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-4.el7
Available: ondemand-nodejs-1.7-5.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-5.el7
Available: ondemand-nodejs-1.7-6.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-6.el7
Available: ondemand-nodejs-1.7-7.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-7.el7
Available: ondemand-nodejs-1.7-8.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-nodejs < 1.9
Removing: ondemand-nodejs-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-nodejs = 1.8-1.el7
Updated By: ondemand-nodejs-2.0-1.el7.x86_64 (ondemand-web)
ondemand-nodejs = 2.0-1.el7
Available: ondemand-nodejs-1.5-5.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.5-5.el7
Available: ondemand-nodejs-1.6-1.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.6-1.el7
Available: ondemand-nodejs-1.6-2.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.6-2.el7
Available: ondemand-nodejs-1.7-2.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-2.el7
Available: ondemand-nodejs-1.7-3.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-3.el7
Available: ondemand-nodejs-1.7-4.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-4.el7
Available: ondemand-nodejs-1.7-5.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-5.el7
Available: ondemand-nodejs-1.7-6.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-6.el7
Available: ondemand-nodejs-1.7-7.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-7.el7
Available: ondemand-nodejs-1.7-8.el7.x86_64 (ondemand-web)
ondemand-nodejs = 1.7-8.el7
Error: Package: ondemand-1.8.19-4.el7.x86_64 (@ondemand-web)
Requires: ondemand-apache < 1.9
Removing: ondemand-apache-1.8-1.el7.x86_64 (@ondemand-web)
ondemand-apache = 1.8-1.el7
Updated By: ondemand-apache-2.0-1.el7.x86_64 (ondemand-web)
ondemand-apache = 2.0-1.el7
Available: ondemand-apache-1.5-5.el7.x86_64 (ondemand-web)
ondemand-apache = 1.5-5.el7
Available: ondemand-apache-1.6-1.el7.x86_64 (ondemand-web)
ondemand-apache = 1.6-1.el7
Available: ondemand-apache-1.6-2.el7.x86_64 (ondemand-web)
ondemand-apache = 1.6-2.el7
Available: ondemand-apache-1.7-2.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-2.el7
Available: ondemand-apache-1.7-3.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-3.el7
Available: ondemand-apache-1.7-4.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-4.el7
Available: ondemand-apache-1.7-5.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-5.el7
Available: ondemand-apache-1.7-6.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-6.el7
Available: ondemand-apache-1.7-7.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-7.el7
Available: ondemand-apache-1.7-8.el7.x86_64 (ondemand-web)
ondemand-apache = 1.7-8.el7

List of currently installed ondemand rpms:
rpm -qa |grep ondemand
ondemand-passenger-6.0.4-7.el7.x86_64
ondemand-gems-1.7.6-1.7.6-1.el7.x86_64
ondemand-ruby-1.8-1.el7.x86_64
ondemand-rubygem-bundler-1.17.3-1.el7.noarch
ondemand-gems-1.7.12-1.7.12-1.el7.x86_64
ondemand-nodejs-1.8-1.el7.x86_64
ondemand-gems-1.8.19-1.8.19-4.el7.x86_64
ondemand-nginx-1.17.3-7.p6.0.4.el7.x86_64
ondemand-gems-1.7.9-1.7.9-1.el7.x86_64
ondemand-runtime-1.8-1.el7.x86_64
ondemand-gems-1.7.10-1.7.10-2.el7.x86_64
ondemand-apache-1.8-1.el7.x86_64
ondemand-gems-1.8.12-1.8.12-1.el7.x86_64
ondemand-python-1.8-1.el7.x86_64
ondemand-1.8.19-4.el7.x86_64
ondemand-gems-1.8.18-1.8.18-1.el7.x86_64
ondemand-gems-1.7.14-1.7.14-1.el7.x86_64
ondemand-release-web-latest-1-6.noarch

Any suggestions? Thanks!
Dori

Also, I’m pointing to your latest repo:
https://yum.osc.edu/ondemand/latest/web/el$releasever/$basearch/

Not dumb at all! We’ve been updating our RPMs for 2.0 release. @tdockendorf please advise.

1 Like

You have a few options. If you want to update just ondemand:

yum update ondemand

If you want to update OS you will have to exclude ondemand:

yum update --disablerepo=ondemand-web

Doing a blanket update will not work at this time due to updates to our latest repo in preparation for building OnDemand 2.0 RPMs. I would strongly recommend not updating to that release at this time because there are numerous breaking changes that we’ve not yet documented. It might be a good idea to switch to OnDemand 1.8 repos for the time being. If you installed repos with RPMs:

yum remove ondemand-release-web-latest
yum install https://yum.osc.edu/ondemand/1.8/ondemand-release-web-1.8-1.noarch.rpm

If you installed repos via some other means just replace latest in URL with 1.8 in the repo file under /etc/yum.repos.d.

Thanks Trey! This is great. We’ll just skip the ondemand update for now. I’m at 1.8.18 in production and it’s working fine. In dev I updated to 1.8.19-4 but haven’t tested it so we’ll leave production as is for now. Thanks!!