Clicking on New ->Python3 in Jupyter notedbook (interactive app) gives Proxy Error message

So, as a test to see if another kernel of python3 with a different name will work, could you follow the instructions here:

To setup another python3 kernel with a different name, the useful-project-name in the example, and see what happens when you try to run a notebook with that new kernel.

Because if that runs fine, there is something wrong with the particular python 3 kernel that the notebook is trying to use. In which case you should remove it and replace with a fresh python3.

We went through this exact error for our system as well.

Upon testing JupyterLab by it itself, we found it was just outright crashing when we made a new notebook. A fresh install of the newest version did not resolve the issue.

In our case, we recently updated our storage from CentOS6 to CentOS7. We did not change any of the mount option on our headnode or compute nodes. For some odd reason, using an NSFv3 mount was the root cause of the issue. We removed the NSFv3 option from the fstab, and let our system default to NSFv4. Afterwards, JupyterLab began working like a charm!

As a word of warning if this is indeed your problem, ACLs changed in NSFv4. It’s no longer exported by rpc and requires a special utility to manage. There is some translation available to help migrate, and a chunk of documentation on the utilities.