Can't connect to mate desktop session

I’m running into some similar issues to this post. I have tried both removing mate-power-manager and hostnamectl set-hostname $hostname.fqdn.com but with no luck. I can manually start up a vncserver and connect to it through a VNC Viewer. However, when I start up an interactive session through the OnDemand portal I can only see Failed to connect to server from noVNC. Do you see anything glaringly wrong when looking at this output.log? My apologies I know this has been discussed before but I’ve made little progress after trying suggestions from older posts.

Desktop 'TurboVNC: (/home/user/ondemand/data/sys/dashboard/batch_connect/sys/bc_desktop/remoteHost/output/b8642ea4-1dba-4150-a7a9-872c0555106e/script.sh: line 7: module: command not found
WebSocket server settings:

  • Listen on :63Scanning VNC log file for user authentications…

Generating connection YAML file…
Initializing caja-open-terminal extension
Initializing caja-image-converter extension
rectory
cat: /etc/xdg/autostart/rhsm-icon.desktop: No such file or directory
cat: /etc/xdg/autostart/xfce4-power-manager.desktop: No such file or directory
generating cookie with syscall
generating cookie with syscall
generating cookie with syscall
generating cookie with syscall
mate-session[160]: WARNING: Could not parse desktop file /home/user/.config/autostart/xfce4-power-manager.desktop: Key file does not start with a group
mate-session[160]: GLib-GObject-CRITICAL: object GsmAutostartApp 0xc36100 finalized while still in-construction
mate-session[160]: GLib-GObject-CRITICAL: Custom constructor for class GsmAutostartApp returned NULL (which is invalid). Please use GInitable instead.
mate-session[160]: WARNING: could not read /home/user/.config/autostart/xfce4-power-manager.desktop
mate-session[160]: WARNING: Could not parse desktop file /home/user/.config/autostart/rhsm-icon.desktop: Key file does not start with a group
mate-session[160]: GLib-GObject-CRITICAL: object GsmAutostartApp 0xc361d0 finalized while still in-construction
mate-session[160]: GLib-GObject-CRITICAL: Custom constructor for class GsmAutostartApp returned NULL (which is invalid). Please use GInitable instead.
mate-session[160]: WARNING: could not read /home/user/.config/autostart/rhsm-icon.desktop
mate-session[160]: WARNING: Could not parse desktop file /home/user/.config/autostart/gnome-keyring-gpg.desktop: Key file does not start with a group
mate-session[160]: GLib-GObject-CRITICAL: object GsmAutostartApp 0xc365e0 finalized while still in-construction
mate-session[160]: GLib-GObject-CRITICAL: Custom constructor for class GsmAutostartApp returned NULL (which is invalid). Please use GInitable instead.
mate-session[160]: WARNING: could not read /home/user/.config/autostart/gnome-keyring-gpg.desktop
vmware-user: could not open /proc/fs/vmblock/dev
SELinux Troubleshooter: Applet requires SELinux be enabled to run.
/usr/share/system-config-printer/applet.py:44: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version(‘Notify’, ‘0.7’) before import to ensure that the right version gets loaded.
from gi.repository import Notify
system-config-printer-applet: failed to start NewPrinterNotification service
system-config-printer-applet: failed to start PrinterDriversInstaller service: org.freedesktop.DBus.Error.AccessDenied: Connection “:1.711” is not allowed to own the service “com.redhat.PrinterDriversInstaller” due to security policies in the configuration file

(nm-applet:289): Gdk-CRITICAL **: 12:02:07.635: gdk_window_thaw_toplevel_updates: assertion ‘window->update_and_descendants_freeze_count > 0’ failed
mate-session[160]: CRITICAL: gsm_systemd_set_session_idle: assertion ‘session_path != NULL’ failed

This is the section I’m looking at. You’re starting on socket :63, not sure how you were able to open that, or maybe you aren’t able to and that’s what’s wrong?

Here’s what mine looks like just now

Desktop 'TurboVNC: p1001.ten.osc.edu:18 (johrstrom)' started on display p1001.ten.osc.edu:18

Log file is vnc.log
Successfully started VNC server on p1001.ten.osc.edu:5918...
Script starting...
Starting websocket server...
Resetting modules to system default
WebSocket server settings:
  - Listen on :4662
  - No SSL/TLS support (no cert file)
  - Backgrounding (daemon)

To debug you have to hop onto that machine while the job is running and determin if websockify is running.

Yes that is rather strange, I’ve just started a new session. I think the message “Scanning VNC log file for user authentications…” is cutting off the rest of the Websockify server settings:. It wasn’t doing that earlier today but it appears to be listening on a different port than the one listed in the log.

In the new session I have:

WebSocket server settings:
  - Listen on :39Scanning VNC log file for user authentications...
ps aux | grep websockify
user   23169  0.0  0.0 108828  9004 ?        S    13:17   
0:00 /usr/bin/python /usr/bin/websockify -D 3974 localhost:5901

Normally I would see something like this:

WebSocket server settings:
  - Listen on :61482
  - Flash security policy server
  - No SSL/TLS support (no cert file)
  - Backgrounding (daemon)

It looks like VNC and Websockify are listening on 5901 and 3974.

netstat -tulpn
tcp        0      0 0.0.0.0:3974            0.0.0.0:*               LISTEN      23169/python
tcp        0      0 0.0.0.0:5901            0.0.0.0:*               LISTEN      23116/Xvnc

Sorry for the late update, I was able to figure this out. I didn’t have any file sharing set up between the OnDemand server and backend resources. After configuring autofs, noVNC works just fine and I can connect to sessions through the OnDemand portal.